Old version of the "dbc-code-contracts" library


#1

Please, update the “dbc-code-contracts” library to the latest version (0.14.1).

The current version, which is available on the RunKit is NOT the latest one (0.12.1).
I have tested the installation via: “npm install” command & all is installing fine. So, why does RunKit provide NOT the latest version?


#2

I may confirm, that all unit-tests at the GitLab CI platform are passed successfully. Also, CD works, so I don’t know why is RunKit keeping the old version. It would be interesting to get known the possible bugs, which are important to fix.


#3

Hi jek-nov and neverlands,

We’re looking into this and have at the very least gotten 0.14.1 available if you manually select node 7 from the pop up (still no luck with 8, and the library uses features not support in node 6 and down). We’ll keep updating you as we making more progress. In the meanwhile, if either of you is the owner of the package or knows the owner of the package, the following two changes would make things a lot easier for us:

  1. The library links to the source ( gitlab.com/o.oleg/orbios.dbc#README ), but the repo is marked private so you can’t actually look at it. It would be super helpful if this library is meant to be open source to mark the repository as public.

  2. Add an “engines” entry to the package.json specifying node 7 or above, given that the library uses features not available in node 6 or down. You can read more about the engines entry here: https://docs.npmjs.com/files/package.json#engines . If you do this, then RunKit will auto-select node 8 on the page and won’t require the user to change the setting away from node 6.

Thanks,

Francisco


#4

Hi, Tolmasky,

I’m the owner of this repo & author of the dbc-library.

The library links to the source, but the repo is marked private so you can’t actually look at it. It would be super helpful if this library is meant to be open source to mark the repository as public.

I have edited the repo settings. Right now, you must able to view sources & CI-builds, for e.g.: https://gitlab.com/o.oleg/orbios.dbc/-/jobs/36260576 (must be visible for the guest)

Add an “engines” entry to the package.json specifying node 7 or above, given that the library uses features not available in node 6 or down. If you do this, then RunKit will auto-select node 8 on the page and won’t require the user to change the setting away from node 6.

I shall include it, in future release (0.15.0+).

Thanks for the given piece of advice,
Best Regards,
neverlands


#6

Taking a look at it now, thanks!


#7

@tolmasky

The RunKit service doesn’t provide the latest library version (which is 0.15.0). Soon, there will be the new one (0.15.1).

The engines entry was specified. May be, the RunKit service has the dependencies on the specific version of the NPM-manager?


#8

@tolmasky @jek-nov

The new version (0.16.0) was published, the last CI-build:

But, the RunKit service provides very old version (0.8.24) at the moment. Also, there is a new item in readme file, the CI-badge. Right now, you’re able to see it at the NPM-website.